Installer la dernière version de Flash Player (23 Beta) pour Firefox

Une petite explication pour installer la dernière version de Flash Player d'Adobe. Adobe ayant récemment décidé de ressusciter son plugin (on était nombreux à fêter la disparition de cette monstruosité). L'explication est donnée pour Firefox sous Debian Jessie (stable).

Évidemment, je ne recommande pas l'installation de Flash Player. C'est juste pour guider les utilisateurs qui ont besoin/envie d'installer la dernière version.

L'installation est simple mais il faudra faire la manipulation pour chaque utilisateur. De même pour les éventuels mises à jours.

Récupérer la dernière version de Flash Player

On choisit la dernière version et qui correspond à son système depuis la page http://labs.adobe.com/downloads/flashplayer.html.
Pour moi, ça correspond à: Download Flash Player for Safari, Firefox and Netscape Plug-In compatible applications – NPAPIDownload Flash Player for Firefox and Netscape Plug-In compatible applications – NPAPI (64-bit)
Et on clique pour télécharger (c'est simplement un fichier nommé libflashplayer.so).

Placer Flash Player dans votre profil Firefox

Il suffit de copier le fichier libflashplayer.so dans votre profil Firefox.
Pour trouver le profil et l'emplacement exact sur votre PC:

  • On rentre dans la barre d'adresse (URL): about:support
  • Dans le premier tableau, face à Répertoire de profil, on clic sur Ouvrir le dossier correspondant.
  • Dans notre gestionnaire de fichier, on se retrouve dans le répertoire: /home/niqnutn/.mozilla/firefox/u7pldei0.default/ (le nom du dossier est différent pour chaque utilisateur)
  • On crée un dossier plugins s'il n'existe pas
  • On copie notre fichier libflashplayer.so dans le dossier plugins (chez moi, ça correspond à /home/niqnutn/.mozilla/firefox/u7pldei0.default/plugins/libflashplayer.so)

Activer la dernière version de Flash Player

Il nous reste à activer la dernière version de Flash Player dans Firefox.

  • On rentre dans la barre d'adresse (URL): about:addons
  • Si vous êtes vraiment décidé à activer Flash Player et prêt à perdre votre âme et votre vie privée, vous pouvez continuer
  • Pour Shockwave Flash 23.0 r0, on sélectionne Toujours activer

Tester le fonctionnement de Flash Player

On va vérifier que le plugin est bien actif et dans sa dernière version.
On se rend sur la page: https://www.adobe.com/fr/software/flash/about/
On a une petite fenêtre Version information, qui devrait indiquer "You have version 23,0,0,162 installed"
Si le plugin n'est pas actif, on voit ce message:

C'est finit .

L'installation est simple mais il faudra recommencer pour chaque utilisateur.
Sinon, il est aussi possible de copier le fichier libflashplayer.so vers /usr/lib/mozilla/plugins/ (nécessite les droits administateur).
De même pour les éventuels mises à jours.

Si vous avez installer le paquet flashplugin-nonfree, deux versions de Flash Player ne peuvent pas cohabiter.
Une solution consiste à supprimer le paquet flashplugin-nonfree pour ne garder que la dernière version du plugin.
Une autre solution consiste à remplacer le plugin directement dans /usr/lib/flashplugin-nonfree/ (cf. https://linuxtrack.net/viewtopic.php?id=2125)

Ressources

4 commentaires

antistress |

Manip réalisée sur la Debian stable 64 bits de mon père (sauf que c'est flashplayer-mozilla qu'il avait, donc j'ai déposé le fichier de la 23 beta dans /usr/lib/flashplayer-mozilla), merci.
Reste la question de la mise à jour ultérieure du bouzin !

nIQnutn |

@antistress :
Merci pour la précision.
Pour la mise à jour, faudra faire à la main.
En même temps; le paquet flashplugin-nonfree était tellement pratique qu'il fallait de toute façon lancer la mise à jour à la main.

antistress |

@ nIQnutn : C'est justement pourquoi il faut privilégier flashplayer-mozilla plutôt que flashplugin-nonfree ; le premier gère les mises à jour automatiquement ;)

Marc17 |

Super tuto ! avec une Debian Jessie j'ai copié libflashplayer.so (extrait de flash_player_npapi_linux_i386.tar.gz) dans /usr/lib/mozilla/plugins et j'ai Flash version 24,0,0,145 activé dans Firefox.
Ensuite j'ai décompressé le reste de l'archive (/usr) dans /usr, fait un chmod +x sur /usr/bin/flash-player-porperties, et j'ai une belle appli pour configurer les "Préférences d'Abode Flash Player".

Merci.

Fil RSS des commentaires de cet article

Écrire un commentaire